SLeepdepD

Apple Still Maintaining Their Illusion of Elitism

by on Oct.20, 2010, under Technology

"Streaming video requires Safari 4 or 5 on Mac OS X Snow Leopard or Safari on iOS 3 or later." -- Either you use our toys or you can't play in the sandbox.

:, ,

Leave a Reply